Shimano spool quality not good | Lure Anglers Forum - Lure Fishing Forum UK (Bass, wrasse..)
Forum Supporting Contributions Upgrade Here

Shimano spool quality not good

Discussion in 'Reels' started by {name}, Jun 19, 2017.

  1. Pollock

    1,459
    1,354
    113
    Location:
    seaford, sussex
    hi all fishing tonight and noticed my year old shimano Stella 3000 spool looks to have a hole corroded in it not good for a year old and washed in fresh cold water after every trip!!! Has anyone seen this happen before IMG_0047.JPG IMG_0049.JPG IMG_0048.JPG
     
  2. Snapper

    4,249
    2,551
    113
    Location:
    Dublin
    Patrick are you sure it's not a chip rather than corrosion. I just know that the modern lightweight composite spools used these days are very delicate and there are a lot of threads about them chipping. It happened with my Stradic FI. I know the Stella is of a much higher spec. But are the spools any better when compared to low to mid-range Shimano's in your experience?
     
  3. Pollock

    1,459
    1,354
    113
    Location:
    seaford, sussex
    Hi Walt I don't know when it could have been chipped as the corrosion is under the line level personaly I have questions regarding shimano quality
     
  4. Wrasse

    554
    221
    43
    Location:
    London/Sussex
    Yes. On an FE. Much worse than that too


    Sent from my iPhone using Tapatalk
     
    • Agree Agree x 1
  5. Perch

    326
    219
    43
    Location:
    Oxford
    I had this on an older sustain a few years ago. Like you, I rinsed after every trip but when I stripped the line off I was horrified to see what looked like salt corrosion had eaten through the spool in several places. It was a seldom used reel too!
     

Share This Page